!
也想出现在这里? 联系我们
广告位
当前位置:首页>技术分享>网站运维>帝国CMS安装错误an Error in a future version of PHP

帝国CMS安装错误an Error in a future version of PHP

今天因为需要测试帝国cms的一个功能,在服务器上面安装了帝国cms,下载了7.5版本,等到安装的时候,第一步,点击“我同意”就出现以下错误了:

PHP Warning: Use of undefined constant can - assumed 'can' (this will throw an Error in a future version of PHP) in D:\********\e\install\data\fun.php on line 121
PHP Warning: Use of undefined constant can - assumed 'can' (this will throw an Error in a future version of PHP) in D:\*******\e\install\data\fun.php on line 240

这里虽然不懂具体是什么意思,但注意到那串英文字符an Error in a future version of PHP,能读懂 version of PHP这个就基本上晓得问题出在哪里了,version是版本的意思,估摸着是php版本的问题,因为是windows服务器,用建站助手直接改动以下版本,前面装的是php7.2,这里我改动到PHP7.1问题就解决了。如果是虚拟主机在虚拟主机面板进行更改。 宝塔面板的话直接在站点设置里面切换php版本,不过前提是要提前预装其他版本的php。

帝国CMS安装错误an Error in a future version of PHP

帝国CMS其实兼容最好的是php5.6,大家如果用帝国的话建议还是用php5.6,以免出现各种php错误。

给TA打赏
共{{data.count}}人
人已打赏
网站运维

帝国CMS7.5后台密码忘记怎么办?

2022-10-11 19:17:51

网站运维

mysql中group by和having的用法

2022-10-11 19:18:26

声明 本站上的部份代码及教程来源于互联网,仅供网友学习交流,若您喜欢本文可附上原文链接随意转载。无意侵害您的权益,请发送邮件至 admin@s9h.cn 或点击右侧 私信:少羽 反馈,我们将尽快处理。
0 条回复A文章作者M管理员
    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索